import re
regex = re.compile(r"\[(.+?)\]\(((?:https?:)?(\/|\\)\3(?:www\.)?.+?\.[a-z]+\3)\)")
test_str = ("This [is a](https://google.com/) text.\n"
"This [is a](https://www.google.com/) text.\n"
"This [is a](http://google.com/) text.\n"
"This [is a](https:\\\\google.com\\) text.\n"
"This [is a](//google.com/) text.\n\n"
"This [is a](https://google./) text.\n"
"This [is a](https://.com/) text.\n"
"This [is a](https://googlecom/) text.\n"
"This [is a](https://google.com) text.")
subst = "<a href=\"$2\">$1</a>"
result = regex.sub(subst, test_str)
if result:
print(result)