#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)([a-zA-Z_$][0-9a-zA-Z_$]*)\s?=\s?new XMLHttpRequest.+?(\1\.((open|send)\(.+?\)))"
Local $sString = "function sendREq(url) {" & @CRLF & _
" var xhr_req=new XMLHttpRequest();" & @CRLF & _
"xhr.onreadystatechange = function() {" & @CRLF & _
" if (xhr.readyState == XMLHttpRequest.DONE) {" & @CRLF & _
" alert(xhr.responseText);" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"xhr_req.open('GET', 'http://example.com', true);" & @CRLF & _
"xhr_req.send(null);" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var namedFunc = function(param1, param2) {" & @CRLF & _
" // return param1 * param2" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"var req = new XMLHttpRequest()" & @CRLF & _
"req.open('POST', 'http://example.com', false);" & @CRLF & _
"req.send(null)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")