const regex = new RegExp('([a-zA-Z_$][0-9a-zA-Z_$]*)\\s?=\\s?new XMLHttpRequest.+?(\\1\\.((open|send)\\(.+?\\)))', 'msg')
const str = `function sendREq(url) {
var xhr_req=new XMLHttpRequest();
xhr.onreadystatechange = function() {
if (xhr.readyState == XMLHttpRequest.DONE) {
alert(xhr.responseText);
}
}
xhr_req.open('GET', 'http://example.com', true);
xhr_req.send(null);
}
var namedFunc = function(param1, param2) {
// return param1 * param2
}
var req = new XMLHttpRequest()
req.open('POST', 'http://example.com', false);
req.send(null)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}