import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z_$][0-9a-zA-Z_$]*)\\s?=\\s?new XMLHttpRequest.+?(\\1\\.((open|send)\\(.+?\\)))";
final String string = "function sendREq(url) {\n"
+ " var xhr_req=new XMLHttpRequest();\n"
+ "xhr.onreadystatechange = function() {\n"
+ " if (xhr.readyState == XMLHttpRequest.DONE) {\n"
+ " alert(xhr.responseText);\n"
+ " }\n"
+ "}\n"
+ "xhr_req.open('GET', 'http://example.com', true);\n"
+ "xhr_req.send(null);\n"
+ "}\n\n"
+ "var namedFunc = function(param1, param2) {\n"
+ " // return param1 * param2\n"
+ "}\n\n"
+ "var req = new XMLHttpRequest()\n"
+ "req.open('POST', 'http://example.com', false);\n"
+ "req.send(null)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}