$re = '/([a-zA-Z_$][0-9a-zA-Z_$]*)\s?=\s?new XMLHttpRequest.+?(\1\.((open|send)\(.+?\)))/ms';
$str = 'function sendREq(url) {
var xhr_req=new XMLHttpRequest();
xhr.onreadystatechange = function() {
if (xhr.readyState == XMLHttpRequest.DONE) {
alert(xhr.responseText);
}
}
xhr_req.open(\'GET\', \'http://example.com\', true);
xhr_req.send(null);
}
var namedFunc = function(param1, param2) {
// return param1 * param2
}
var req = new XMLHttpRequest()
req.open(\'POST\', \'http://example.com\', false);
req.send(null)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);