use strict;
my $str = 'function sendREq(url) {
var xhr_req=new XMLHttpRequest();
xhr.onreadystatechange = function() {
if (xhr.readyState == XMLHttpRequest.DONE) {
alert(xhr.responseText);
}
}
xhr_req.open(\'GET\', \'http://example.com\', true);
xhr_req.send(null);
}
var namedFunc = function(param1, param2) {
// return param1 * param2
}
var req = new XMLHttpRequest()
req.open(\'POST\', \'http://example.com\', false);
req.send(null)
';
my $regex = qr/([a-zA-Z_$][0-9a-zA-Z_$]*)\s?=\s?new XMLHttpRequest.+?(\1\.((open|send)\(.+?\)))/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}