#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<\s*(\/?\s*)(b|i|u|br|button|div)(\s?|\s+[\s\S]*?)(\/)?\s*>"
Local $sString = "<b>" & @CRLF & _
"</b>" & @CRLF & _
"< b >" & @CRLF & _
"< /b >" & @CRLF & _
"" & @CRLF & _
"<br>" & @CRLF & _
"<br/>" & @CRLF & _
"<br /><br />" & @CRLF & _
"<br/ >" & @CRLF & _
"<br / >" & @CRLF & _
"< br / >" & @CRLF & _
"" & @CRLF & _
"<button id="myButton" readonly />button content</button/>" & @CRLF & _
"" & @CRLF & _
"<div class="myClass">div content</div>" & @CRLF & _
"<div class="myClass" >div content</ div>" & @CRLF & _
"<div class="myClass" />" & @CRLF & _
"" & @CRLF & _
"// NOT CONVERTED" & @CRLF & _
"<bb>" & @CRLF & _
"A > B" & @CRLF & _
"B <= C"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")