// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<\s*(\/?\s*)(b|i|u|br|button|div)(\s?|\s+[\s\S]*?)(\/)?\s*>").unwrap();
let string = "<b>
</b>
< b >
< /b >
<br>
<br/>
<br /><br />
<br/ >
<br / >
< br / >
<button id=\"myButton\" readonly />button content</button/>
<div class=\"myClass\">div content</div>
<div class=\"myClass\" >div content</ div>
<div class=\"myClass\" />
// NOT CONVERTED
<bb>
A > B
B <= C";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}