using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*(\/?\s*)(b|i|u|br|button|div)(\s?|\s+[\s\S]*?)(\/)?\s*>";
string input = @"<b>
</b>
< b >
< /b >
<br>
<br/>
<br /><br />
<br/ >
<br / >
< br / >
<button id=""myButton"" readonly />button content</button/>
<div class=""myClass"">div content</div>
<div class=""myClass"" >div content</ div>
<div class=""myClass"" />
// NOT CONVERTED
<bb>
A > B
B <= C";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}