package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<\s*(\/?\s*)(b|i|u|br|button|div)(\s?|\s+[\s\S]*?)(\/)?\s*>`)
var str = `<b>
</b>
< b >
< /b >
<br>
<br/>
<br /><br />
<br/ >
<br / >
< br / >
<button id="myButton" readonly />button content</button/>
<div class="myClass">div content</div>
<div class="myClass" >div content</ div>
<div class="myClass" />
// NOT CONVERTED
<bb>
A > B
B <= C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}