import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*(\\/?\\s*)(b|i|u|br|button|div)(\\s?|\\s+[\\s\\S]*?)(\\/)?\\s*>";
final String string = "<b>\n"
+ "</b>\n"
+ "< b >\n"
+ "< /b >\n\n"
+ "<br>\n"
+ "<br/>\n"
+ "<br /><br />\n"
+ "<br/ >\n"
+ "<br / >\n"
+ "< br / >\n\n"
+ "<button id=\"myButton\" readonly />button content</button/>\n\n"
+ "<div class=\"myClass\">div content</div>\n"
+ "<div class=\"myClass\" >div content</ div>\n"
+ "<div class=\"myClass\" />\n\n"
+ "// NOT CONVERTED\n"
+ "<bb>\n"
+ "A > B\n"
+ "B <= C";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}