use strict;
my $str = '<b>
</b>
< b >
< /b >
<br>
<br/>
<br /><br />
<br/ >
<br / >
< br / >
<button id="myButton" readonly />button content</button/>
<div class="myClass">div content</div>
<div class="myClass" >div content</ div>
<div class="myClass" />
// NOT CONVERTED
<bb>
A > B
B <= C';
my $regex = qr/<\s*(\/?\s*)(b|i|u|br|button|div)(\s?|\s+[\s\S]*?)(\/)?\s*>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}