const regex = /<\s*(\/?\s*)(b|i|u|br|button|div)(\s?|\s+[\s\S]*?)(\/)?\s*>/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*(\\\/?\\s*)(b|i|u|br|button|div)(\\s?|\\s+[\\s\\S]*?)(\\\/)?\\s*>', 'gi')
const str = `<b>
</b>
< b >
< /b >
<br>
<br/>
<br /><br />
<br/ >
<br / >
< br / >
<button id="myButton" readonly />button content</button/>
<div class="myClass">div content</div>
<div class="myClass" >div content</ div>
<div class="myClass" />
// NOT CONVERTED
<bb>
A > B
B <= C`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}