using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^moduleFor\('(.*?)'\)$";
string substitution = @"moduleFor('$1', 'unit@$1')";
string input = @"moduleFor('mixin:foo')
// or
moduleFor('route:bar')";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}