$re = '/^moduleFor\(\'(.*?)\'\)$/m';
$str = 'moduleFor(\'mixin:foo\')
// or
moduleFor(\'route:bar\')';
$subst = "moduleFor('$1', 'unit@$1')";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;