import Foundation
let pattern = #"^moduleFor\('(.*?)'\)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
moduleFor('mixin:foo')
// or
moduleFor('route:bar')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"moduleFor('$1', 'unit@$1')"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)