use strict;
my $str = 'moduleFor(\'mixin:foo\')
// or
moduleFor(\'route:bar\')';
my $regex = qr/^moduleFor\('(.*?)'\)$/mp;
my $subst = 'moduleFor(\'$1\', \'unit@$1\')';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";