re = /^moduleFor\('(.*?)'\)$/m
str = 'moduleFor(\'mixin:foo\')
// or
moduleFor(\'route:bar\')'
subst = 'moduleFor(\'$1\', \'unit@$1\')'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result