package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^moduleFor\('(.*?)'\)$`)
var str = `moduleFor('mixin:foo')
// or
moduleFor('route:bar')`
var substitution = "moduleFor('$1', 'unit@$1')"
fmt.Println(re.ReplaceAllString(str, substitution))
}