const regex = /^moduleFor\('(.*?)'\)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^moduleFor\\(\'(.*?)\'\\)$', 'gm')
const str = `moduleFor('mixin:foo')
// or
moduleFor('route:bar')`;
const subst = `moduleFor('$1', 'unit@$1')`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);