import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S+\\s\\d+\\/\\d+\\/\\d+";
final String string = "Buxtehude /1234 KundenAuftragEinsatzart1 698874/6387/01\n"
+ "KundenAuftragEinsatzart 698874/6387\n"
+ "Musterstadt /1234 KundenAuftragEinsatzart2 698874/6387/01\n"
+ "KundenAuftragEinsatzart3 698874/6387/01\n"
+ "KundenAuftragEinsatzart4 698874/6387/01";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}