re = /\S+\s\d+\/\d+\/\d+/m
str = 'Buxtehude /1234 KundenAuftragEinsatzart1 698874/6387/01
KundenAuftragEinsatzart 698874/6387
Musterstadt /1234 KundenAuftragEinsatzart2 698874/6387/01
KundenAuftragEinsatzart3 698874/6387/01
KundenAuftragEinsatzart4 698874/6387/01'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result