import re
regex = re.compile(r"\S+\s\d+\/\d+\/\d+", flags=re.MULTILINE)
test_str = ("Buxtehude /1234 KundenAuftragEinsatzart1 698874/6387/01\n"
"KundenAuftragEinsatzart 698874/6387\n"
"Musterstadt /1234 KundenAuftragEinsatzart2 698874/6387/01\n"
"KundenAuftragEinsatzart3 698874/6387/01\n"
"KundenAuftragEinsatzart4 698874/6387/01")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)