$re = '/\S+\s\d+\/\d+\/\d+/m';
$str = 'Buxtehude /1234 KundenAuftragEinsatzart1 698874/6387/01
KundenAuftragEinsatzart 698874/6387
Musterstadt /1234 KundenAuftragEinsatzart2 698874/6387/01
KundenAuftragEinsatzart3 698874/6387/01
KundenAuftragEinsatzart4 698874/6387/01';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;