# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:\d{4}[ -]?){3}(?=\d{4}\b)/**** **** **** /gm;t' <<< "Hi here is my card number its visa 4242 4242 4242 4242
Hi here is my card number its visa 4242424242424242
Hi here is my card number its visa 4242-4242-4242-4242"