use strict;
my $str = 'Hi here is my card number its visa 4242 4242 4242 4242
Hi here is my card number its visa 4242424242424242
Hi here is my card number its visa 4242-4242-4242-4242';
my $regex = qr/\b(?:\d{4}[ -]?){3}(?=\d{4}\b)/mp;
my $subst = '**** **** **** ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";