using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:\d{4}[ -]?){3}(?=\d{4}\b)";
string substitution = @"**** **** **** ";
string input = @"Hi here is my card number its visa 4242 4242 4242 4242
Hi here is my card number its visa 4242424242424242
Hi here is my card number its visa 4242-4242-4242-4242";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}