$re = '/\b(?:\d{4}[ -]?){3}(?=\d{4}\b)/m';
$str = 'Hi here is my card number its visa 4242 4242 4242 4242
Hi here is my card number its visa 4242424242424242
Hi here is my card number its visa 4242-4242-4242-4242';
$subst = "**** **** **** ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;