import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:\\d{4}[ -]?){3}(?=\\d{4}\\b)";
final String string = "Hi here is my card number its visa 4242 4242 4242 4242\n"
+ "Hi here is my card number its visa 4242424242424242\n"
+ "Hi here is my card number its visa 4242-4242-4242-4242";
final String subst = "**** **** **** ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}