#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(?:\d{4}[ -]?){3}(?=\d{4}\b)"
Local $sString = "Hi here is my card number its visa 4242 4242 4242 4242" & @CRLF & _
"Hi here is my card number its visa 4242424242424242" & @CRLF & _
"Hi here is my card number its visa 4242-4242-4242-4242"
Local $sSubst = "**** **** **** "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)