import Foundation
let pattern = #"\b(?:\d{4}[ -]?){3}(?=\d{4}\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hi here is my card number its visa 4242 4242 4242 4242
Hi here is my card number its visa 4242424242424242
Hi here is my card number its visa 4242-4242-4242-4242
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"**** **** **** "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)