using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s\w\b|\b\w\s)";
string substitution = @"";
string input = @"a b c d e f g h ijkl m n opqrst u v";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}