use strict;
my $str = 'a b c d e f g h ijkl m n opqrst u v';
my $regex = qr/(?:\s\w\b|\b\w\s)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";