$re = '/(?:\s\w\b|\b\w\s)/';
$str = 'a b c d e f g h ijkl m n opqrst u v';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;