const regex = /(?:\s\w\b|\b\w\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s\\w\\b|\\b\\w\\s)', 'g')
const str = `a b c d e f g h ijkl m n opqrst u v`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);