import Foundation
let pattern = #"(?:\s\w\b|\b\w\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"a b c d e f g h ijkl m n opqrst u v"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)