package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s\w\b|\b\w\s)`)
var str = `a b c d e f g h ijkl m n opqrst u v`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}