re = /(?:\s\w\b|\b\w\s)/
str = 'a b c d e f g h ijkl m n opqrst u v'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result