# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)/$0,/g;t' <<< "12345678"