const regex = /(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\b\\d|\\G)\\d+?(?=(?:\\d{3})+\\b)', 'g')
const str = `12345678`;
const subst = `$0,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);