use strict;
my $str = '12345678';
my $regex = qr/(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)/p;
my $subst = '$0,';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";