$re = '/(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)/';
$str = '12345678';
$subst = "$0,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;