import Foundation
let pattern = #"(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"12345678"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0,"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)