using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)";
string substitution = @"$0,";
string input = @"12345678";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}