import re
regex = re.compile(r"(?=\b\d|\G)\d+?(?=(?:\d{3})+\b)")
test_str = "12345678"
subst = "$0,"
result = regex.sub(subst, test_str)
if result:
print(result)