# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{2})\.(\d{2})-(\d{4})/$1\/$2\/$3/gm;t' <<< "01.10-2016"