re = /(\d{2})\.(\d{2})-(\d{4})/m
str = '01.10-2016'
subst = '$1/$2/$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result