$re = '/(\d{2})\.(\d{2})-(\d{4})/m';
$str = '01.10-2016';
$subst = "$1/$2/$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;