const regex = /(\d{2})\.(\d{2})-(\d{4})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{2})\\.(\\d{2})-(\\d{4})', 'gm')
const str = `01.10-2016`;
const subst = `$1/$2/$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);