import re
regex = re.compile(r"(\d{2})\.(\d{2})-(\d{4})", flags=re.MULTILINE)
test_str = "01.10-2016"
subst = "$1/$2/$3"
result = regex.sub(subst, test_str)
if result:
print(result)